一乐电子

一乐电子百科

 找回密码
 请使用微信账号登录和注册会员

QQ登录

只需一步,快速开始

快捷登录

手机号码,快捷登录

搜索
查看: 2636|回复: 19
收起左侧

[DP50数控电源] DP50W-3USB v1.8 锂电充电中途拔走锂电无法返回主菜单

[复制链接]
发表于 2014-5-23 21:46 | 显示全部楼层 |阅读模式
本帖最后由 hardtoy2004 于 2014-5-23 21:50 编辑

我的DP50W-3USB 已升级固件v1.8 ,也成功调校好电压电流。尝试试验DP50W的各种功能。
在试用锂电充电功能时,插上锂电池充电顺利(锂电池电压当时是3.95V),充电了几分钟后,
发觉在充电途中若拔走锂电(那时我想试验其它使用功能),DP50却锁定在锂电充电的版面,未能返回正常的菜单页面。
直按电流拨盘开关时只显示<请先断开电池>,但即使拔走电池,电池电压仍显示4.18V (充满转涓流)
充电电流显示44mA。所以程序无法返回菜单。此时按电压拨盘开关并没反应,拔除主供电源再接回重启都没用。

由于没法返回主菜单,我只好重刷固件v1.8。
刷好固件后再试第二次的锂电充电功能,但仍旧是同样情况。

我尝试把板子上锂电充电输出的电容(25V 47uF)短路释放余电,但仍没法清除电池电压显示的4.18V。所以没法返回菜单。
这次把电源拔开,断电了约30分钟,再插电启动才发觉<电池电压>显示为0V,这时才能返回主菜单!

为什么不能中途停止锂电充电,断开电池转用其它功能?
不知到这是程序的问题还是我独有的"功能"。

拔走锂电

拔走锂电

直按电流拨盘开关时只显示<请先断开电池>

直按电流拨盘开关时只显示<请先断开电池>
发表于 2014-5-23 22:09 | 显示全部楼层
标示是你板子的问题。。我手里的没这现象。。
发表于 2014-5-23 22:45 | 显示全部楼层
从现象来说感觉是程序跑飞了 挂了  软件出BUG的概率相对大点
发表于 2014-5-23 22:47 | 显示全部楼层
你多试几次  看现象是否能复现  
 楼主| 发表于 2014-5-23 23:05 来自手机 | 显示全部楼层
折腾的趣味就是多试验,一次成功就没味儿啰
发表于 2014-5-23 23:46 来自手机 | 显示全部楼层
估计软件的可能性更大
发表于 2014-5-23 23:47 | 显示全部楼层
我刷了V1.8各项功能均正常啊,锂电充电途中拔走电池,电池电压及电流都回零,就是输出电压升至5.18V,重新进入充电界面就正常了。楼主的这个问题重点检查一下充电MOS回路和焊接。
 楼主| 发表于 2014-5-24 11:37 | 显示全部楼层
本帖最后由 hardtoy2004 于 2014-5-24 16:31 编辑

谢谢各位的指导。

我继续测试锂电充电的功能。
这次发现即使没有接上锂电池,DP50W也会自行显示<电池电压>4.18V !!!

1. 没有接上锂电池
2. 进入<锂电充电>功能, 初始时<电池电压>显示0V
3. 等待几秒后,<电池电压>显示4.183V
4. 按电流拨盘,显示<先断开电池>

若要电池电压>返零,要手动调校:
1. 将设定电流手动减少到少于涓流电流43mA
2. 调至35mA时,<电池电压>显示0V
3. 这时按电流拨盘,就能显示菜单,回复正常开机版面

若果是硬件的问题?会是那个零件的问?
要不是要焊走3R33才能动下面的零件呵!


初始时<电池电压>显示0V

初始时<电池电压>显示0V

几秒后显示4.183V

几秒后显示4.183V

按电流拨盘,显示<先断开电池>

按电流拨盘,显示<先断开电池>

调至35mA时显示0V

调至35mA时显示0V

回复正常开机版面

回复正常开机版面
 楼主| 发表于 2014-5-24 12:21 来自手机 | 显示全部楼层
更正:1.没有接上锂电池
发表于 2014-5-24 14:35 | 显示全部楼层
把板子另一面来个高清图吧!

清洗下板子。

本版积分规则

QQ|一淘宝店|手机版|商店|电子DIY套件|一乐电子 ( 粤ICP备09076165号 ) 公安备案粤公网安备 44522102000183号

GMT+8, 2024-5-21 09:13 , Processed in 0.069253 second(s), 37 queries , Gzip On.

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表